[WordPress] Error con extensión mysqli tras actualizar PHP

Mientras actualizaba la versión PHP de mi servidor local, un sitio en desarrollo bajo WordPress + WooCommerce dejó de funcionar y comenzó a mostrar el siguiente aviso:

Revisé php.ini y la dichosa extensión estaba activa y además existía en la carpeta de extensiones.

Cabe señalar que la actualización fue entre ramas menores, es decir, de la 8.1.6 a la 8.1.27. En algunos sitios leí que podía ser un conflicto de versiones, así que me decanté por esta vía.

Borré todo el contenido de la carpeta /php/ exceptuando el archivo php.ini, busqué el extraible con la última versión de PHP, y me percato de algo muy importante: solo había un .zip con PHP 8.1.27, el NTS, que suelo utilizar para un proyecto secreto que eventualmente revelaré, mientras que Apache necesita la variante TS. Descargué la variante TS, la copie en la carpeta de PHP y ejecuté Apache: el error desapareció.

Entonces, para recapitular: utilizar la variante NTS en un servidor Apache genera comportamientos inesperados con cierto software, y aunque a simple vista funcione, solo usa la maldita versión correcta.

Más vivito pa la otra